Does Amplify software work with Firefox or Internet Explorer?

At this time, Amplify software is designed for use with Chrome or Safari browsers. Firefox and Internet Explorer are not supported.

Did this answer your question?